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1.1 Introduction

EtherNet/IP™ is the most commonly used industrial communication protocol managed by Open 
DeviceNet Vendors Association (ODVA). EtherNet/IP is an application layer protocol that is 
transferred inside a TCP/IP Packet. That means that EtherNet/IP is simply the way data is organized in 
a TCP or UDP packet. EtherNet/IP is part of CIP, the Common Industrial Protocol. CIP defines the 
Object structure and specifies the message transfer. CIP protocol over Ethernet is EtherNet/IP.

This document describes how to enable EtherNet/IP protocol support in Smart Wireless Gateway 
(Gateway). This document also explains the procedure to import Order Options, enable protocol 
support, and establish various types of connections with Rockwell ControlLogix® PLC using Class1, 
UCMM, and Class3 connections.

The document also explains about understanding different user interface pages within the Smart 
Wireless Gateway. These pages include, EtherNet/IP statistics, the communication page, and how to 
map device variables in the EtherNet/IP mapping page. It is assumed that there is general knowledge 
of how to establish connections using the Rockwell ControlLogix PLC. Consult the manual for the 
specific PLC. This document is just aimed at users looking to incorporate data values from the Smart 
Wireless Gateway. For assistance, contact your local wireless specialist.
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1.2 Preparing the Gateway for EtherNet/IP 
connection

1.2.1 Importing EtherNet/IP Order Option 

Before importing the order option

Note
If the Gateway was pre ordered with the EtherNet/IP option, skip to “Enable EtherNet/IP 
Protocol” on page 4. If this is a field upgrade, follow these directions. An option file will need to 
be purchased for all field upgrades. Contact your local Emerson representative or contact 
information at the end of this manual.

Figure 1-1. Smart Wireless Gateway
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Once an option file has been obtained navigate to Setup>Firmware options. Under Select a 
Gateway option file, browse to the option file. See Figure 1-1 on page 2.

After selecting the EtherNet/IP order option file associated with the correct Gateways HG serial 
number, select the Submit button to apply the changes and proceed to Restart the Applications 
as seen below in Figure 1-2.

An application restart is necessary for the installation to be complete. Navigate to 
Setup>Restart Applications if not prompted.

Note
This will result in a temporary loss in communications with the network and will require a 
network rebuild. The mesh network is maintained, however, the devices will need to establish a 
connection to the Gateway. WARNING - All communications back to the host will be lost.

Figure 1-2. Setup Restart Applications

After importing the order option
After restarting the Gateway, navigate to the Setup>Firmware Options page. The check mark 
should be seen as shown to ensure that the EtherNet/IP Order Options imported successfully in 
the Smart Wireless Gateway.
3Allen-Bradley Integration



Manual Supplement
00809-0500-4420, Rev BB

Allen-Bradley Integration
April 2015
Figure 1-3. Setup >Firmware options after EtherNet/IP Install

1.2.2 Enable EtherNet/IP Protocol 

Navigate to the Setup>Security>Protocols page to enable the EtherNet/IP Protocol. The 
Gateway needs to restart in order to apply the changes. 

Select the Enable checkbox and press the Submit button to enable the EtherNet/IP Protocol in 
the Gateway as shown below. Restart the application to apply the changes.

Navigate to Setup>Security>Protocols page. Ensure that the EtherNet/IP Protocol checkbox is 
enabled as shown in the below screenshot and that there are no error messages on the Protocol 
Page. A browser reset/cache clear may be required for the option to fully display.
4 Allen-Bradley Integration
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1.2.3 EtherNet/IP Web Pages

EtherNet/IP mapping page

Navigate to the Setup>EtherNet/IP>EtherNet/IP Mapping page to map various device 
variables in Instance Pairs (100-101 or 102-103 or 104-105).

Note
If no devices are configured with the Gateway or if all devices are offline, enable the Include 
Gateways option from the HART>Hierarchy page for initial EtherNet/IP communication with the 
Smart Wireless Gateway. In that case, the user can map wihartgw.PV, wihartgw.QV, etc. This web 
page is also useful while reading values from ControlLogix to understand in which pair and as 
which member user has mapped his particular device variable.

Below represents the EtherNet/IP mapping page of the Gateway. See Table 1-1 on page 1-5 for 
detailed explanations of the available options. 

Figure 1-4. Setup>EtherNet/IP>EtherNet/IP Mapping

Table 1-1.  Summary of Terms used for the EtherNet/IP Mapping Page

Terms Description

Input Instance EtherNet/IP Input Static Assembly Instance - 496 bytes.

Output Instance EtherNet/IP Output Static Assembly Instance - 496 bytes.

Member EtherNet/IP Instance Member in which data will get produced or consumed.

Point Name Assigned data point in the format HARTtag.parameter.

New entry Creates a new entry in this table.
5Allen-Bradley Integration
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EtherNet/IP communication page

This section contains basic information about EtherNet/IP Protocol and error value representa-
tion. See Table 1-2 on page 1-6 for details on each section.

Terms Description

<<First Navigates to the first page of this table.

<<Previous Navigates to the previous page of this table.

Search Finds the next occurrence of the characters entered into this field.

Next>> Navigates to the next page of this table.

Last>> Navigates to the last page of this table.

Delete Selected Removes the selected entry from this table.

Select All Selects all table entries.

Select None De-selects all table entries.

Select Errors Selects all table entries that have an error message.

Submit Accepts all changes (highlighted in yellow).

Table 1-2.  Setup>EtherNet/IP>EtherNet/IP Communication

Terms Description

Assembly Object Type EtherNet/IP use Static assembly object.

EtherNet/IP TCP Port The TCP Port used to access EtherNet/IP TCP data directly from the 
Gateway.

EtherNet/IP UDP Ports The UDP Ports used to access EtherNet/IP UDP data directly from the 
Gateway.

Incorporate value’s 
associated status as 
error?

If the HART® variable status indicates a critical failure or if there is a loss of 
communications, it will be reported through the EtherNet/IP member.

Value reported for error 
(floating point)

Chooses what value is reported if the value’s associated status indicates a 
critical failure. Only used if the Gateway is using float representation

NaN Not a number is reported if the value’s associated status indicates a critical 
failure.

+Inf Positive infinity is reported if the value’s associated status indicates a critical 
failure.

-Inf Negative infinity is reported if the value’s associated status indicates a 
critical failure.

Other User defined value is reported if the value’s associated status indicates a 
critical failure.

Value reported for error 
(native integer)

User defined value is reported if the value’s associated status indicates a 
critical failure. Only used if the Gateway is using integer representation.

Table 1-1.  Summary of Terms used for the EtherNet/IP Mapping Page
6 Allen-Bradley Integration
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Import/export page

Table 1-3 on page 1-7 shows the Import/Export Mapping page. The Import/Export of mapped 
entries can be saved for later use or they can import settings that have already been created in 
the.CSV file format.

EtherNet/IP stats page

The EtherNet/IP Stats Page shows the Communication/Connection Statistics. Navigate to 
Diagnostics>Advanced>EtherNet/IP Stats page.

Table 1-3.  Setup>EtherNet/IP> Import/Export

Terms Description

CSV file Comma delimited or comma separated file format.

Browse… Opens a navigation window to locate a EtherNet/IP mapping backup file 
(CSV file) on the PC client.

Upload Configuration Restores the select EtherNet/IP mapping backup file to the Gateway.

Download Configuration
Collects the Gateway EtherNet/IP mapping data and creates a backup 
file. This EtherNet/IP mapping backup file is saved on the PC client as a 
CSV file (*.csv).

Table 1-4.  Diagnostics > Advanced > EtherNet/IP Stats

Terms Description

Message Received Total number of class 3 Received messages.

Message Sent Total number of class 3 Sent messages.

UCMM Received Total number of UCMM Received messages.

UCMM Sent Total number of UCMM Sent messages.

UCMM Error Response Total number of failed UCMM Read/Write Request.

I/O Packets Received Total number of received class 1 packets.

I/O Packets Sent Total number of sent class 1 packets.

I/O Packets Failed to Sent Number of packets that have failed to send.

I/O Packets Received Error Number of packets that have failed to be received.

Active connections Total number of connections established with EtherNet/IP 
Adapter (Smart Wireless Gateway).

Current I/O Message Connections Shows total number of active Class 1 connections.

Current CIP Message Connections  Shows total number of active Class 3 connections.

Reset Counts Clicking this button will reset all EtherNet/IP Statistics counts to 
zero.
7Allen-Bradley Integration
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1.3 Connecting to the ControlLogix PLC

This section assumes knowledge of Allen-Bradley software. The IO Module is configured with a 
valid IP address on the same subnet as the Gateway and the PC.

A basic knowledge of the Emerson Smart Wireless Gateway is required. The Gateway will need 
to be configured with a valid IP address on the same subnet as the Allen-Bradley control system 
and the PC.

The Emerson 1420 device uses multiple Class 1 CIP connections within a Generic Profile. The 
latest version of RSLogix5000 is required for you to use this capability. This requires V19 and 
higher of RSLogix5000. V20 of RSLogix5000 includes features that automatically populate 
parameters such as for input/output instances for the Generic CIP Module making some of the 
steps in this manual unnecessary.

Note
 The PLC processor has to be taken offline to be configured, then downloaded to accept 

the EtherNet/IP setup. This means the protocol can't be implemented when the process 
is running. 

 EtherNet/IP can only be implemented on ControlLogix processor firmware revision 17 
and up.

 EtherNet/IP will only work on the Ethernet 1 connection on the Gateway. 

 When mapping data, only use one input “instance” and one output “instance”. An 
Allen-Bradley Ethernet card can only handle one instance per setup in the PLC.

 EtherNet/IP can only be implemented on redundant ControlLogix processors starting 
with firmware revision 20 and above.

 See “Other information” on page 36 for limitations with explicit messaging before 
proceeding.

Section 1.3.2, 1.3.4, 1.3.5 and 1.3.6 detail connecting to the ControlLogix PLC using four 
separate methods, Class 1 Connections: CIP BUS Module, UCMM Connection, Class 3 
Connections and Generic Gateway Module respectively. The methods are defined below. Use 
only one of these methods to connect to the PLC.

Class 1 Connections (I/O): CIP BUS Module - Establishes a periodic exchange of data between a 
scanner and an adapter. Messages are sent as connected messages which utilize resources 
within each node that are dedicated in advance to a particular purpose. The messaging is 
implicit and is time-critical in nature. Implicit messaging (or I/O) is typically used for real-time 
data exchange when speed and low latency is important. They include very little information 
about their meaning so its transmission is more efficient, but less flexible than explicit.

UCMM Connection (explicit messaging - unconnected) - Commands or data requests sent 
from the scanner to individual target nodes (Class 3 messages). Unconnected messaging is used 
during connection establishment and for infrequent, low-priority messages. The Unconnected 
Message Manager, or UCMM, refers to the unconnected resources in a device. Explicit 
messaging connections in general are request-response transactions between two nodes 
typically used for non-real time data, normally for information. They include a description of 
their meaning so the transmission is very flexible but less efficient.
8 Allen-Bradley Integration



Manual Supplement 
00809-0500-4420, Rev BB

Allen-Bradley Integration
April 2015
Class 3 Connection - Similar to UCMM connection Class 3 connection is used for individual 
request/response transactions. A request from a scanner always results in a response from the 
adapter indicating the success or failure of the request. Messaging is explicit and connected 
rather than unconnected.

Generic Gateway Module - Similar to CIP BUS Module the Generic Gateway Module is 
established to move application specific I/O data at regular intervals. The Generic Gateway 
Module however establishes class 1 connection to a single pair at a time whereas the Ethernet 
CIP BUS Method allows connection to multiple pairs.

For status and output capability, the use of the CIP Bus method is recommended. It should be 
noted that the CIP Bus method does require more memory than the generic Gateway method.

These are just examples of ways to bring in the data from the network. There are many possible 
configurations.

Note
For instructions on how to first establish a connection to the Gateway, see either the Quick Start 
Guide (document number 00825-0200-4420) or the Smart Wireless Gateway manual 
(document number 00809-0200-4420).

1.3.1 Importing Smart Wireless Gateway EDS file using EDS 
hardware installation tool

Note
Before doing connections with the controller, the user should import the EDS file of the Smart 
Wireless Gateway in RSLogix. Navigate to Start>Programs>Rockwell Software>Version 2.56 
>RSLinx>Tools>EDS Hardware Installation Tool. The .eds file can be obtained by contacting 
Specialist-Wireless.EPM-RTC@EmersonProcess.com with Allen-Bradley EDS file in the subject line.

Equipment used
 Emerson 1420 Gateway with firmware 4.4 or higher and EtherNet/IP enabled (Gateway 

Page>Setup>Security>Protocols)

 1 or more WirelessHART® devices connected to the Emerson 1420 Gateway

1. After Launching the EDS Hardware installation tool, select Add.

2. Make sure that Register a single file is selected by default. If not, select it.

3. Browse for the Smart Wireless Gateway EDS file and select Next until there is successful 
installation of Smart Wireless Gateway’s EDS file. Select Finish after installation of the 
EDS file.

If your EDS installation wizard is successful, in RSLinx Utility you can see Smart Wireless Gateway 
as a recognized device with the name Wireless Gateway - EtherNet/IP and device logo. 
9Allen-Bradley Integration
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1.3.2 Establishing a Class 1 connection (I/O): CIP BUS Module

1. Power ON the PLC.

2. Run the RSLogix application and create a new configuration. (Navigate to File>New)

3. Enter the appropriate controller information and Name. Select OK.

a. Choose the controller model from the drop down list. (This is the specific controller 
model that you are using and may be different than the one used in the image 
below).

b. Set the proper revision for the controller.

c. Give the Project a name.

d. Choose the chassis type used from the dropdown list.

e. Select the slot that the controller occupies.

4. Choose where to save the project and select OK.

Note
When using Compactlogix you don’t need to select a slot.
10 Allen-Bradley Integration
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5. Add 1756-ENET/B to RSLogix I/O configuration

a. Right click on the I/O Configuration node in the Controller Organizer view and select 
New/Add Module.

b. In the Select Module Type dialog select 1756-ENET/B entry.

c. RSLogix will open the Module Properties dialog box. Enter the IP address of the 
1756-ENET/B bridge and select OK. This is user determined. In this example, the PLC 
address was 192.168.1.21.

You may download the configuration to make sure the operation was successful. 
11Allen-Bradley Integration
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Add the Gateway as a module in RSLogix

1. Ensure that EtherNet/IP protocol is enabled in the Smart Wireless Gateway. See Figure 
1-3 on page 4 for instructions.

2. Right click on the Ethernet section, under the 1756-ENET/B EnetBridge node, under I/O 
Configuration, in the Controller Organizer view and select New Module.

3. Under Communication, choose Generic EtherNet/IP CIP Bridge.

4. Enter the Name and IP Address of the Emerson Smart Wireless Gateway and select OK.
12 Allen-Bradley Integration
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5. Right click on the CIP Bus tab and select New Module.

6. Choose Generic CIP module and select OK.

7. Select OK. This will open the Module Properties dialog.

8. Enter the appropriate name (Instance_Pair1) and Connection parameters. Choose the 
appropriate data type from the dropdown list. Depending on the chosen data type, 
choose the data size in bytes.

Note
Total Data size should be 496 bytes for each instance. Enter the Input Connection Point (Output 
Instance no. of Device), Output Connection Point (Input Instance no. of Device), and 
Configuration Connection Object Instance as 1. For more information on total data size, see 
Table 1-5 below or “Other information” on page 36.

Table 1-5.  Total Data Size Table

Comm. format - data type Input instance size (bytes) Output instance size (bytes)

DINT 124 124

INT 248 248

SINT 496 496

REAL 124 124
13Allen-Bradley Integration



Manual Supplement
00809-0500-4420, Rev BB

Allen-Bradley Integration
April 2015
9. Select OK to add the example to the I/O Configuration. 

Note
Repeat steps 4 to 9 to establish connection to Instance Pair2 (Input=103 - Output=102) and 
Instance Pair3 (Input=105 - Output=104).

10. A new ETHERNET-MODULE branch of 1756-ENET/B EnetBridge node will appear in the I/O 
Configuration view.

11. New entries will also appear in the Controller Tags view: Smart_Wireless_Gateway:0: I to 
view the input data, 
Smart_Wireless_Gateway:0: O to modify the output data and 
Smart_Wireless_Gateway:0: C to view the configuration data.
14 Allen-Bradley Integration



Manual Supplement 
00809-0500-4420, Rev BB

Allen-Bradley Integration
April 2015
Save the configuration

1. Use Communications/Download to download the new I/O configuration to the 
controller. 

2. If you haven't download the PLC before, you'll have to select the appropriate driver. 
Navigate to Communication>Who Active. Browse through the appropriate driver and 
download the project in the controller as shown.

3. Once the download is complete, the controller will automatically establish a new Class1 
connection with the device through EtherNet/IP. It will use the configuration 
parameters entered in the Module Properties dialog.
15Allen-Bradley Integration
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1.3.3 Viewing class1 data on ControlLogix 

Note
Class1 connections should be used with experienced users that understand how to implement 
messaging. Consult the Controllogix manual.

1. Switch RSLogix to the Remote Run mode. 

2. Open Instance_Pair1: I and Instance_Pair1: O nodes by clicking on the plus sign in 
front of the nodes. 

3. Values should appear as per selected data type during Configuration. 
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1.3.4 UCMM connection (explicit messaging - unconnected)

1. Start RSLogix, Verify that PLC is ON.

2. Navigate to File>New.

3. Enter the appropriate Controller information and Name. Select OK.

4. Right click on I/O Configuration and select New Module.
17Allen-Bradley Integration
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5. Navigate to Communications>1756 ENET/B 1756 Ethernet communication 
interface as shown and select OK.

6. Enter Name and Description if the user wants and the IP address of the PLC. Keep the 
other fields as is.
18 Allen-Bradley Integration
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7. Select OK and finish the configuration of the PLC, make sure that the new Ethernet tab is 
appearing as shown. Save the Configuration.

8. In the Controller Organizer menu, right click on Controller Tags and click on New Tag...

9. In the New Tag window give the appropriate name and description for explicit (UCMM) 
message.

10. Select Type>Base, Data Type>MESSAGE, External Access as Read or Read/Write 
depending on the requirement.

11. Select OK.
19Allen-Bradley Integration
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12. Again in the Controller Organizer menu, right click on Controller Tags and select New 
Tag.

13. In the New Tag window, give the appropriate name and description for message data 
type.

14. Select Type>Base, Data Type>Data Type of Parameter to Read/Write, External Access 
as Read or Read/Write depending on requirement.

15. Choose Style as per data type.

16. Select OK.

17. Save the made configuration. Make sure that you are able to see the above configured 
tag in Controller Tags as shown.
20 Allen-Bradley Integration
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18. Right click on Tag which is created in step 8(MESSAGE) and select Configure Tag.

19. In the Message Configuration table, choose Message Type as CIP generic.

20. Set Service Type as Get Attribute Single or Set Attribute Single depending on 
read/write.

21. Enter the values of the Class, Instance, and Attribute you want to read write.

22. Choose the configured tag in step 12 (Message data) as a destination and click on 
Apply.
21Allen-Bradley Integration



Manual Supplement
00809-0500-4420, Rev BB

Allen-Bradley Integration
April 2015
23. Navigate to Communication in the same table and browse for the DUT path. Choose 
the path. <PLC><SLOT NUMBER><SMART WIRELESS Gateway IP ADDRESS>

24. Select Apply and Save the configuration.
22 Allen-Bradley Integration
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25. Select Main Routine in the tree structure.

26. Add the Message Block from Input/output to rung.

27. Configure this message block as Message tag (tag which is configured in step 3).
23Allen-Bradley Integration



Manual Supplement
00809-0500-4420, Rev BB

Allen-Bradley Integration
April 2015
You can check the configured Message and data by selecting View Configuration 
Dialogue box as shown.

28. Save and Download the configuration in Controller.
24 Allen-Bradley Integration
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29. To view the data go to Run mode and navigate to Controller Tags.
25Allen-Bradley Integration
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1.3.5 Class 3 connection (explicit messaging - connected)

1. Repeat all steps of UCMM Connection.

Note
In the Message Configuration block, under Communication, make sure Connected block is 
selected.

2. Apply and Save the configuration settings.

3. To view the data, go to Run mode and navigate to Controller Tags.
26 Allen-Bradley Integration
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1.3.6 Utilizing the Generic Gateway Module

Note
Revision 17 and above is required for EtherNet/IP.
When using Compactlogix, you do not need to select a slot.

1. Power ON the PLC.

2. Run the RSLogix application and create a new configuration. Navigate to File>New.

3. Enter the appropriate Controller information and Name. Select OK.

a. Choose the controller model from the drop down list.

b. Set the proper revision for the controller.

c. Give the project a name.

d. Choose the chassis type used from the dropdown list.

e. Select the slot the controller occupies.

4. Choose where to save the project and select OK.
27Allen-Bradley Integration
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Add 1756-ENet/b to RSLogix I/O configuration

1. Right click on the I/O Configuration node in the Controller Organizer view and select 
New/Add Module.

2. In the Select Module Type dialog choose 1756-ENET/B entry. 

3. RSLogix will open the Module Properties dialog box. Enter the IP address of the 
1756-ENET/B bridge and select OK to add the Interface to your I/O configuration.

You may download the configuration to make sure the operation was successful. 
28 Allen-Bradley Integration
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Add Gateway as a module in RSLogix

1. Ensure that EtherNet/IP protocol is enabled in Wireless Gateway. 

2. Right click on the Ethernet section, under the 1756-ENET/B EnetBridge node, under I/O 
Configuration, in the Controller Organizer view and select New Module. 

3. In the Select Module Type dialog choose Generic Ethernet Module.

4. Click OK. This will open the Module Properties dialog.

5. Enter an IP address of the Smart Wireless Gateway in which EtherNet/IP application is 
running.

6. Enter appropriate name (here Instance_Pair1) and connection parameters. 
Select the appropriate data type from the dropdown list.
Depending on the selected data type choose the data size in bytes.
29Allen-Bradley Integration
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Note
Total Data size should be 496 bytes for each instance. Enter the Input Connection Point (Output 
Instance no. of Device), Output Connection Point (Input Instance no. of Device), and 
Configuration Connection Object Instance as 1. For more information, see “Other information” 
on page 36.

7. Select OK to add the example to the I/O Configuration. 

8. You should see a new ETHERNET-MODULE Instance_Pair1 branch of the 1756-ENET/B 
EnetBridge node in the I/O Configuration view. You should also see 3 new entries in the 
Controller Tags view: Instance_Pair1:I to view the input data, Instance_Pair1:O to modify 
the output data and Instance_Pair1:C to view the configuration data: 

9. Save and Download the configurations to the controller:

Use Communications/Download to download the new I/O configuration to the 
controller. Once the download is complete, the controller will automatically establish a 
new Class1 connection with the configured Instance Pair. It will use the configuration 
parameters entered in the Module Properties dialog. 

Note
In Generic Ethernet Module method, you can establish class 1 connection with single pair at a 
time. For establishing Class 1 Connection to multiple pairs use Ethernet bridge CIP Bus method.

Comm. format - data type Input instance size (bytes) Output instance Size (bytes)

DINT 124 124

INT 248 248

SINT 496 496

REAL 124 124
30 Allen-Bradley Integration
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1.4 Write functionality using RSLogix 5000

Note
This manual describes write functionality for the CIP Bus Method.

1. Navigate to Setup>EtherNet/IP>EtherNet/IP Mapping.

2. Map the Rosemount 702 writable points in the EtherNet/IP mapping page.

Figure 1-5. EtherNet/IP Member Map

Note
In this example the Rosemount 702 Discrete Wireless Transmitter has both channels set to 
output and the variables set to on/off (to be either 1 or 0)

3. Observe the mapped variable values in the webpage as shown in the Explorer page or in 
the Device Published data page.

Figure 1-6. Explorer
31Allen-Bradley Integration
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Figure 1-7. Explorer >Choose Hart Tag of Device>Published Data 

4. Establish a Class 1 Connection with the Smart Wireless Gateway using RSLogix 5000 if 
not already established.

a. Repeat steps 1 to 5 of Class1 Connection (I/O).

b. If a connection is established successfully, navigate to Controller Tags>Input 
section (I) as shown in the below screenshot. It will show the present value of 
mapped Rosemount 702 parameters.
32 Allen-Bradley Integration
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Note
In this example the CHANNEL_1_SETPOINT_D and CHANNEL_2_SETPOINT_D are 16 bit 
integers. This will require a Generic CIP module of the INT data type. If the module is not of the 
INT data type a new module must be created for this to be changed.

5. Navigate to the Output section.

6. Write the appropriate value in the output tabs as shown. (In this case 1 is written to both 
mapped parameters.)

Note
Data is written properly only in online mode.
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7. Navigate to the Input tab again and observe the changed value as shown.
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1.5 Troubleshooting

1.6 Other information

1. Only 124 members are allowed for mapping per pair.

In EtherNet/IP, Each Instance Pair can hold the data up to 496 bytes, but the user can 
only map a maximum of 124 members per instance pair. (Whatever may be the data 
type of mapped variables, for e.g. If user wants to map all Boolean variables in particular 
instance, maximum 124 Boolean variables they can map in the selected instance pair.) 
Some of the hosts support maximum 1500 bytes of data. Hence presently for device 
variable mapping chosen 3 instance pairs of size 496 bytes each. 

2. 32-bit error value, for the Point Name which does not exist or the Point Name which is 
having bad status while first time mapping.

While mapping of a particular variable for the first time, if mapped variable status is 
bad/offline, EtherNet/IP will treat that variable as 32 bit (Undefined Data). So as shown 
in communication page, it will show the error as 32 bit value. (Whatever may be the 
actual data type of mapped variable).

3. The user can map variables/Point Names of mix data types in any instance pair. 
(100-101, 102-103, 104-105) In this case it’s user’s responsibility to find a particular 
mapped variable value in RSLogix Class1 I/O Connection. Here depending on different 
data types (8, 16, 32 bit) user need to see mapped variable values in Class 1 
Connection.

Problem Suggested solution

Unable to see the Gateway on rslinx as 
described, although the EDS file was 
successfully installed. 

We consider that the machine on which rslinx is 
installed is in the same subnet as the Gateway. We can 
explicitly add the Gateway IP address by choosing the 
AB_ETH-1 driver. See attached screenshots. Also 
screenshots for EDS file Installation (Allen-Bradley 
Integration Document are in the user manual already.

Unable to find where to allocate the 
'reliability' float and the tools for 'online,' 
'PV_healthy,' etc. How do I poll them? Is it a 
different class instance? (The manual only 
shows dint/int/real/sint).

Float = real, Booleans also can be mapped. You can 
map any variable which you can see on Explorer>Device 
Name>Published data web page and read in RsLogix 
with the datatype mentioned on web page.

Are the definitions for 
SYSTEM_DIAG.ADDITIONAL_STATUS shown 
anywhere for the predefined registers?

Navigate to Explorer>Device name(e.g.wihartgw)>See 
Additional status tab.Let us know if you are looking for 
anything else by means of definition.

Do Predefined Registers hold last state if the 
instrument goes offline like the data does?

It will not hold the last state like other data, It will 
change according to the particular parameter status i.e 
good or bad. (Whatever Additional status is seen in the 
webpage, the same will appear in the RSLogix).
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4. Rosemount 702 written data becomes zero after reestablishment of Class 1, Class 3 
Connections.

 EtherNet/IP uses producer consumer model. So on every RPI EtherNet/IP scanner 
and adapter produces its own data for each other. 

 In Rosemount 702 write case, whenever Class 1, Class3 connection 
re-establishes, scanner will produce data with all zeros so Smart Wireless 
Gateway adapter will consume this data. 

 In case of Class 1, Class 3 connection reestablishment, the previous written data 
to Rosemount 702 devices will be zero (Here only those writable variable values 
become zero, which mapped to that particular instance). The user needs to 
record the Rosemount 702 written data before removing the particular 
connection and rewrite again.

5. Currently in the application there are 3 pairs of assembly objects 100-101, 102-103, 
104-105 (decimal) can be read. The mapped values from 101, 103 & 105 (in case of 
explicit messaging) can be read depending on the mapping done in webpage.

6. Regarding Input Size 124: 

Size of assembly object is 496 bytes (fixed). When you are reading DINT or REAL (float 
values) which are of 4 bytes you have to read it as an array. For example, float values 
from the assembly object which is 496 bytes, so the size will be 124 or 496/4. If you 
want to read values as INT (2 bytes), the size will be 248, 496/2.

Note
Retaining old values vs. using “all zeros” on a new connection is “scanner specific” functionality, 
there are no rules in EtherNet/IP specs about this behavior.
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